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A
A WebObjects 
Application
Welcome to the Fun part ! This chapter will guide you through a 
complete process from where to get FrontBase for FREE, through 
the database model and table definition/creation, and web applica-
tion development.

This chapter will guide you through the following:

– “Overview” on page 5.

– “Package Installation” on page 5.

– “Creation of the Contacts Database” on page 12.

– “Enterprise Object Model Creation” on page 26.

– “Table Creation” on page 14.

– “WebObjects Application Creation” on page 44.

– “Running the WOContacts Application” on page 130.

Overview
FrontBase is available for FREE download at www.frontbase.com. 

Package Installation
1. After decompressing the downloaded package, you will 

have a file FrontBase-MacOSX-<version>.mpkg as seen in 
Figure A.1
Users Guide   FB–5
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Figure A.1 FrontBase-MacOSX-<version>.mpkg

2. You are now presented with a window as seen in Figure A.2, 
showing you the components that will be installed. Notice 
the checkboxes are all checked. Since this is our first install, 
we leave them all checked.
FB–6   Users Guide 
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Figure A.2 Components to be Installed

3. Click the Install button and you will be prompted to confirm 
the installation. To confirm the installation click the "Con-
tinue" button as seen in Figure A.3.
Users Guide   FB–7
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Figure A.3 Confirm Installation

4. If you already have a version of FrontBase installed, you will  
be informed that some of the files are already installed as 
seen in Figure A.4. That is ok, click on the "Continue" button.
FB–8   Users Guide 
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Figure A.4 Files Have Been Found

5. The installer will now proceed to install FrontBase on your 
computer. When installation is complete you will see the 
panel as shown in Figure A.5.
Users Guide   FB–9
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Figure A.5 Installation Complete

6. The frontBase engine, FBExec is started automatically as part 
of the installation process. To verify that it is open a terminal 
window and execute the following command, as seen in Fig-
ure A.6. 

ps axc | grep FBExec
FB–10   Users Guide 
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Figure A.6 FBExec Verification

NOTE: To open a terminal window, from the Workspace Man-
ager navigate and double click /System/Administration/Termi-
nal.app.

If for some reason for some reason the FBExec is not running, try to 
launch it from the same Terminal window by using the following 
command: 

/Local/Library/FrontBase/bin/FBExec &

If it still does not start, please e-mail all the messages to:
support@FrontBase.com. 

NOTE:  It is normal to see a single start-up message upon man-
ual start-up.
Users Guide   FB–11
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Creation of the Contacts Database

FBDatabaseManager
1. Create a FBDatabaseManager shortcut. From the Workspace 

Manager navigate to /Local/Applications/FBDatabaseMan-
ager.app as seen in Figure A.7

Figure A.7 Create a FBDatabaseManager shortcut

2. Click and drag the FBDatabaseManager.app to your Desk-
top. Now start-up FBDatabaseManager by double clicking on 
this icon as seen in Figure A.8.
FB–12   Users Guide 
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Figure A.8 Starting FBDatabaseManager

3. From the Menu choose Database->Create and you will be 
prompted for Host name and Database name. Enter your 
host, click "Add" and enter Contacts for the Database name, 
click “Select” as seen in Figure A.9.

Figure A.9 Create Contacts

4. Your database has been created and it will now be started 
and displayed in the Monitor as seen in Figure A.10.
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Figure A.10 Verification in Monitor

Table Creation

EOModeler
1. Create an EOModeler shortcut. From the Workspace Man-

ager navigate to /System/Developer/Applications/EO-
Modeler.app as seen in  Figure A.11.
FB–14   Users Guide 
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Figure A.11 Create an EOModeler Shortcut

2. Click and drag the EOModeler.app to your Desktop. Now 
start-up EOModeler by double clicking on this icon. Choose 
Model->New from the menu and  choose FrontBase for the 
adaptor to be used for your application, as seen in Figure 
A.12.
Users Guide   FB–15
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Figure A.12 Starting EOModeler

3. Click the "Next" button and enter Contacts for the Database 
name, your hostname for the Host name and click “Login” as 
seen in Figure A.13.
FB–16   Users Guide 
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Figure A.13 Define the Database

4. You will then be prompted to what to include in you data-
base EOModel, click "Finish" as seen in Figure A.14.
Users Guide   FB–17
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5. It is a good idea to save your model now.

Choose Model->Save and click on Library and enter 

Models/Contacts in the Name field as seen in Figure A.15.

Figure A.15 Saving the Model

6. You might be prompted for a Nonexisting path if you do not 
have a Models Folder. Click "Create" to create the Folder and 
model file as seen in Figure A.16.

Figure A.16 Path Creation

7. Your model should now reflect the new database name "Con-
tacts" as seen in Figure A.17.
Users Guide   FB–19
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Figure A.17 The Contacts EOModel

To start creating Entities in EOModeler, 

8. Choose Property->Add Entity your window should look like 
Figure A.18.
FB–20   Users Guide 
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Figure A.18 Creating Table Entities

9. Under the "Name" column, double click the Entity entry and 
replace it with Contact, double click in the field under the 
"Table" column and enter CONTACT, finally double click 
EOGenericRecord under the "Class Name" column and enter 
Contact as seen in Figure A.19.
Users Guide   FB–21
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10.Repeat the previous 2 steps for the tables Company and 
Product so your model looks like Figure A.20. 
FB–22   Users Guide 
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Figure A.20 The Complete Contacts EOModel

11.Click Model->Save to save you model. You will see a Consis-
tency Check, Figure A.21  stating that your tables do not have 
any primary keys defined. Click OK, because you are now 
going to define your tables in the next section.
Users Guide   FB–23
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EOAdaptor Connection Dictionary Keys

The following keys are known the the FrontBase EOadaptor.  The 
keys are case sensitive and the values of the databaseName has the 
case sensitivity of the underlying file system.

– databaseName       NSString        The name of the database  

– userName               NSString           The  database  name  of the  
user, default the login name

– hostName               NSString       The name of the host, de-
faults to current host

– databasePassword NSString       The digested database 
password, default none

– password                  NSString       The digested password 
for the user, default none

– debugFile                 NSString       A file to write debug info 
into, opened append write 

– debug                      NSNUmber  The debug level

0: off

1: on
FB–24   Users Guide 
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– catalogName    NSString      The catalog name, defaults to 
current database

– schemaName    NSString      The schema name, defaults to 
the default schema for the user

– isolationLevel   NSNumber  The isolation level, defaults to 
SERIALIZABLE

0: ISOLATION LEVEL READ UNCOMMITTED

1: ISOLATION LEVEL READ COMMITTED

2: ISOLATION LEVEL REPEATABLE READ

3 :ISOLATION LEVEL SERIALIZABLE

2: ISOLATION LEVEL VERSIONED

– updateability      NSNumber   The updatability, defaults 
to READ WRITE

0: READ WRITE

1: READ ONLY

– lockingDisciplineNSNumber  The locking dicipline, de-
faults to pessimistic

0: LOCKING PESSIMISTIC

1: LOCKING DEFERRED

2: LOCKING OPTIMISTIC

– firstBatchSize       NSNumber  The number of rows 
fetched in the first batch, default 200

– nextBatchSize       NSNumber  The number of rows 
fetched in subsequent batches, default 200

The passwords must be digested.  This is done withe the Class 
method of the class FBPasswordDigest something like:

[FBPasswordDigest digestPassword:pw user:@"_SYSTEM"];
Users Guide   FB–25
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NOTE: The pw is the password that the user entered, and the 
user is the uppercase user name.  For the database password you 
must use _SYSTEM and the user. 

FBPasswordDigest is defined in the FBAccess framework, in the 
header file FBPasswordDigest.h

Enterprise Object Model Creation

The Company Table
1. The SQL for the table will be as follows:

SET TRANSACTION ISOLATION LEVEL SERIALIZABLE, LOCKING 
PESSIMISTIC;
DROP TABLE "Company" CASCADE;
CREATE TABLE "Company"
( "Address1"   VARCHAR(255),
  "Address2"   VARCHAR(255),
  "City"       VARCHAR(255),
  "Contact_Id" INT,
  "Country"    VARCHAR(255),
  "Email"      VARCHAR(64),
  "Name"       VARCHAR(255),
  "Product_Id" INT,
  "State"      VARCHAR(255),
  "Telephone"  VARCHAR(64),
  "Zip"        VARCHAR(64)
);
DELETE FROM INFORMATION_SCHEMA.EOMODELER_RELATIONS WHERE 
"SCHEMA_NAME" = CURRENT_SCHEMA AND SOURCE_TABLE = 'COMPANY';

INSERT INTO INFORMATION_SCHEMA.EOMODELER_RELATIONS VALUES 
(CURRENT_SCHEMA,'toContact',0,0,'COMPANY','(CONTACT_ID)','CONTAC
T','(CONTACT_ID)');

INSERT INTO INFORMATION_SCHEMA.EOMODELER_RELATIONS VALUES 
(CURRENT_SCHEMA,'toProduct',0,0,'COMPANY','(PRODUCT_ID)','PRODUC
T','(PRODUCT_ID)');
FB–26   Users Guide 
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ALTER TABLE "Company" ADD PRIMARY KEY 
("Contact_Id","Product_Id") NOT DEFERRABLE INITIALLY IMMEDIATE;
ALTER TABLE "Company" ADD FOREIGN KEY ("Product_Id") REFERENCES 
"Product" ("Product_Id") DEFERRABLE INITIALLY DEFERRED;
ALTER TABLE "Company" ADD FOREIGN KEY ("Contact_Id") REFERENCES 
"Contact" ("Contact_Id") DEFERRABLE INITIALLY DEFERRED;
COMMIT;

2. To create the Company Table click on the "Company" entry 
in the left frame of EOModeler and make sure that you see 
the following columns:

– Name

– Value Class

– External Type

– Width

– Column

– Value

as seen in Figure A.22. If you do not have all the columns, choose 
the "Add Column" drop down button in the Company Attributes 
section to add the desired column. You may have to add the "Value" 
column for example.
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Figure A.22 Company Table Creation

Add the Table Attributes
1. To add attributes to the Company table you will choose 

Property->Add Attribute and your window will look like 
Figure A.23.
FB–28   Users Guide 
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Figure A.23 Adding Company Attributes

2. The Company table will have a relationship with the Contact 
and Product table so you will create a key to hold the ID's of 
each of the table data. To create the key entry first click under 
the "key" icon, next click under the "diamond" icon to dese-
lect the column, next double click the "Attribute" entry under 
the Name column and enter contactID, double click under 
the Value Class and enter NSNumber, next choose INT for 
the External Type column, double click under the Column 
column and enter CONTACT_ID, next double click and fi-
nally enter i under the Value column. Repeat this for the pro-
ductID so that your Company table looks like Figure A.24.
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Figure A.24 Adding the ContactID Key

3. The rest of the fields will be of NSString Value Class and 
VARCHAR External Type. I will step you through the name 
and you will do the same steps for all of the fields in the 
Company table. Once again choose Property->Add Attribute 
from the menu. Double click the "Attribute" entry under the 
Name column and enter name, double click under the Value 
Class and enter NSString, next choose VARCHAR for the Ex-
ternal Type column, double click under the Width column 
and enter 255, double click under the Column column and 
enter NAME. Repeat this for all the rest of the attributes de-
fined above so that your Company table looks like Figure 
A.25.
FB–30   Users Guide 
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Figure A.25 Adding the Name Attribute

1. The procedure for the Contact table is the same as the Com-
pany table. The table definition for the Contact table is as fol-
lows:

SET TRANSACTION ISOLATION LEVEL SERIALIZABLE, LOCKING 
PESSIMISTIC;
DROP TABLE "Contact" CASCADE;
CREATE TABLE "Contact"
( "Address1"   VARCHAR(255),
  "Address2"   VARCHAR(255),
  "City"       VARCHAR(255),
  "Contact_Id" INT,
  "Country"    VARCHAR(255),
  "Email"      VARCHAR(64),
  "Name"       VARCHAR(255),
  "State"      VARCHAR(64),
Users Guide   FB–31
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  "Telephone"  VARCHAR(64),
  "Zip"        VARCHAR(64)
);
DELETE FROM INFORMATION_SCHEMA.EOMODELER_RELATIONS WHERE 
"SCHEMA_NAME" = CURRENT_SCHEMA AND SOURCE_TABLE = 'CONTACT';

INSERT INTO INFORMATION_SCHEMA.EOMODELER_RELATIONS VALUES 
(CURRENT_SCHEMA,'toCompany',0,1,'CONTACT','(CONTACT_ID)','COMPAN
Y','(CONTACT_ID)');

SET UNIQUE = 1000000 FOR "CONTACT";
ALTER TABLE "Contact" ADD PRIMARY KEY ("Contact_Id") NOT 
DEFERRABLE INITIALLY IMMEDIATE;
COMMIT;

2. After  you have followed the steps to create the Contact table 
you definition should look like Figure A.26.
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Figure A.26 Contact Table Creation

1. The procedure for the Product table is the same as the Com-
pany table. The table definition for the Product table is as fol-
lows:

SET TRANSACTION ISOLATION LEVEL SERIALIZABLE, LOCKING 
PESSIMISTIC;
DROP TABLE "Product" CASCADE;
CREATE TABLE "Product"
( "Name"       VARCHAR(255),
  "Price"      FLOAT,
  "Product_Id" INT
);
DELETE FROM INFORMATION_SCHEMA.EOMODELER_RELATIONS WHERE 
"SCHEMA_NAME" = CURRENT_SCHEMA AND SOURCE_TABLE = 'PRODUCT';

INSERT INTO INFORMATION_SCHEMA.EOMODELER_RELATIONS VALUES 
(CURRENT_SCHEMA,'toCompany',0,1,'PRODUCT','(PRODUCT_ID)','COMPAN
Y','(PRODUCT_ID)');

SET UNIQUE = 1000000 FOR "PRODUCT";
ALTER TABLE "Product" ADD PRIMARY KEY ("Product_Id") NOT 
DEFERRABLE INITIALLY IMMEDIATE;
COMMIT;

2. After you have followed the steps to create the Product table 
your definition should look like Figure A.27. 

3. Choose Model->Save to save your model. You are now going 
to add Relationships to your tables in the next section.
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Figure A.27 Create the Product Table

Creating Relationships
1. It is now time to create the relationships that will join our ta-

bles together. First click on the Contact table entry in the left 
frame of EOModeler. Then you should see you table defini-
tion for the Contact table. 

2. From the menu choose Property->Add Relation as seen in 
Figure A.28.
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Figure A.28 Adding Contact Relationships

3. From the menu choose Tools->Inspector to bring up the Rela-
tionship inspector. You are going to add a One-To-Many re-
lationship to the Company table. Enter toCompany in the 
name, next select the Company table from the Entity list, next 
select the "To Many" radio button, finally select contactID 
from the Source Attributes list and contactID from the Desti-
nation Attributes List. Click on Connect and you should see 
the selections have a "dimple" to show the connection has 
been completed. See Figure A.29.
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Figure A.29 Defining the Relationship

4. Your model should also show the relationship. Make sure 
that there is a ‘>>’ by the relationship, if not that means that 
you only have a one-to-one relationship. See Figure A.30.
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Figure A.30 One-To-Many Relationship

1. For the Company table, you will have 2 one-to-one relation-
ships. The first to the Contact table and the second to the 
Product table. Follow the steps that you performed in the 
Contact table except DO NOT select the “To Many “radio 
button. These are just to be one-to-one relationships. Your re-
lationship for the Contact table should look like Figure A.31.
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Figure A.31 Company Relationship To Contact Table

2. The second relationship is to the Product table. Your relation-
ship for the Contact table should now look like Figure A.32.
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Figure A.32 Company Relationships To Product Table

1. For the Product table, you will have 1 one-to-many relation-
ship. You are going to add a One-To-Many relationship to 
the Company table. Enter toCompany in the name, next se-
lect the Company table from the Entity list, next select the 
"To Many" radio button, finally select productID from the 
Source Attributes list and productD from the Destination At-
tributes List. Click on “Connect” and you should see the se-
lections have a "dimple" to show the connection has been 
completed. See Figure A.33.
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Figure A.33 Product Table Relationships

1. If you would like to see a Diagram View of what your data-
base looks like, Choose Tools->Diagram View and your 
model should look like Figure A.34.
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Figure A.34 The Diagram View of the Relationships

1. You have now created your model, but you still have to cre-
ate the actual tables in the FrontBase Contacts database. Se-
lect the Contacts entry in the left frame of the EOModeler, 
from the menu choose Property->Generate SQL and you will 
see a window as in Figure A.35.
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Figure A.35 Generating SQL

2. Select Execute SQL and you will see an Alert for each of the 
tables See Figure A.36. This is ok because the SQL is trying to 
drop the table and create it again. Since the table does not 
exist yet, it cannot drop it thus you get the alert. Just click the 
"Continue" button for each of the tables.
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Figure A.36 Creating the Physical Tables

Congratulations, you have now defined and created your Contacts 
database tables. You may quit EOModeler. You are ready to create 
your WebObjects Application in the next section.
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ProjectBuilder
1. Create a ProjectBuilder shortcut. From the Workspace Man-

ager navigate to /System/Developer/Applications/Project-
Builder.app as seen in  Figure A.37.

Figure A.37 Create a ProjectBuilder Shortcut

2. Click and drag the ProjectBuilder.app to your Desktop. Now 
start-up ProjectBuilder by double clicking on this icon. 
Choose Project->New from the menu and you will choose  
WebObjects Application from the Project Type popup but-
ton, navigate to the folder where you want the project to be 
placed (I chose LocalDeveloper) and then enter WOContacts 
in the Name field and click “OK” as seen in Figure A.38.
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Figure A.38 Create a New Project

Create the Contact Entry Page
1. You are going to first create the main window that will be for 

our Contacts using the Contact table. On the first window of 
the WebObjects Application Wizard, choose the "Wizard" 
radio button and Primary Language "Java" as seen in Figure 
A.39, then click “Next”.
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Figure A.39 Create the Main Component

2. You will now choose the database model that you just cre-
ated in the last section. Choose the "Open existing model file" 
radio button. Then choose the “Browse” and navigate to the 
LocalLibrary/Models/Contacts.eomodel selection as seen in 
Figure A.40 and click “OK”.
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Figure A.40 Choosing the Contacts EOModel

3. Your model selection window should appear as seen in Fig-
ure A.41, and click “Next”.
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Figure A.41 Selecting the EOModel

4. Since the main page will be a search and entry for Contacts, 
choose the Contact table as seen in Figure A.42, and click 
“Next”.
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Figure A.42 Select the Contact Table

5. Select "Selected Record" and "Matching Records" as seen in 
Figure A.43, and click “Next”.
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Figure A.43 Choosing a Page Layout

6. It is time to select what fields will be displayed in the win-
dow. For this application double click on all of  them so your 
window looks like Figure A.44, and click “Next”.
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Figure A.44 Choosing the Attributes To Display

7. For this application we are going to make the telephone 
number the field that will be our hyperlink. 

8. Double click telephone as seen in Figure A.45, and click 
“Next”.
Users Guide   FB–51



A WebObjects Appl icat ion
WebObjects Application Creation
Figure A.45 Choosing an Attribute for the Hyperlink

9. To query the database for entered Contacts, we will use the 
name, telephone and email fields. Double click these fields 
respectively as seen in Figure A.46, and click “Finish”.
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Figure A.46 Choosing the Attribute to Query On

10.You have now created the project and your Contacts entry 
screen. You are now in the Project Builder's Main Window as 
seen in Figure A.47. From here you will add more windows, 
build and edit all of you files and run your WebObjects Con-
tacts application.
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Create the ProductEntry Page
1. Click on the "Web Components" entry in the left column and 

you will see "Main.wo", this is your main Web Component. 
You will now create a screen for the Product table by select-
ing File->New in Project from the Project Builder's menu. 
Click on the "Web Component" suitcase and enter Pro-
ductEntry in the Name field as seen in Figure A.48, and click 
“OK”.
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Figure A.48 Adding the ProductEntry Component

2. Make sure the "Component Wizard" and "Java" are selected 
as seen in Figure A.49,and click “Next”.
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Figure A.49 Using the Component Wizard

3. Choose the Product entity from the list as seen in Figure 
A.50, and click "Next".

Figure A.50 Choosing the Product Table

4. Select "Selected Record" and "Matching Records" as seen in 
Figure A.51, and click "Next".
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Figure A.51 Choosing the Page Layout

5. Double click on name and price as seen in Figure A.52, and 
click "Next".
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Figure A.52 Choosing the Attributes to Display

6. Double click on the name field that will be the hyperlink for 
the product window, as seen in Figure A.53, and click "Next".
FB–58   Users Guide 



A WebObjects Appl icat ion
WebObjects Application Creation

FB

FB

FB

FB

FB

FB

FB

FB

FB

FB

FB

FB
Figure A.53 Choosing the Attribute for the Hyperlink

7. Double click on the name field that will be the search field for 
the product, as seen in Figure A.54, and click "Finish".
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Figure A.54 Choosing the Attributes to Query On

8. Notice that now in ProjectBuilder you will see ProductEn-
try.wo under the Main.wo entry as seen in Figure A.55.
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Figure A.55 Addition of the ProductEntry Component

Create the CompanyEntry Page
1. You will now create a screen for the Company table by select-

ing File->New in Project from the Project Builder's menu. 
Click on the "Web Component" suitcase and enter Company-
Entry in the Name field as seen in Figure A.56, and click 
"OK".
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Figure A.56 Creation of the CompanyEntry Component

2. Make sure the "Component Wizard" and "Java" are selected 
as seen in Figure A.57,and click "Next".
FB–62   Users Guide 



A WebObjects Appl icat ion
WebObjects Application Creation

FB

FB

FB

FB

FB

FB

FB

FB

FB

FB

FB

FB
Figure A.57 Choosing the Component Wizard

3. Choose the Company table from the list as seen in Figure 
A.58, and click "Next".

Figure A.58 Choosing the Company Table

4. Select "Selected Record" and "Matching Records" as seen in 
Figure A.59, and click "Next".
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Figure A.59 Choosing the Page Layout

5. Double click name, address1, address2, city, state, zip, coun-
try, telephone and email as seen in Figure A.60, and click 
"Next".
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Figure A.60 Choose the Attributes to Display

6. Double click name for the hyperlink value as seen in Figure 
A.61, and click "Next".
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Figure A.61 Choosing the Attribute for the Hyperlink

7. Double click name for the name to query on as seen in Figure 
A.62, and click "Finish".
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Figure A.62 Choosing the Attribute to Query On

8. Notice that now in ProjectBuilder you will see CompanyEn-
try.wo under the Main.wo entry as seen in Figure A.63.
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Figure A.63 Addition of the ProductEntry Component

Create the ContactDetails Page
1. It is now time to create the Contact Details page. This is the 

page that will show all the relationships for a selected Con-
tact. For this we will not automatically include a database ta-
ble, so all that has to be done is to create an empty compo-
nent page. To do that, choose File->New in Project from the 
menu. Click on the "Web Components" suitcase and enter 
ContactDetails in the Name field as seen in Figure A.64, and 
click "OK".
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Figure A.64 Creation of the ContactDetails Component

2. In the Component Wizard make sure that "None" and "Java" 
are selected and click "Finish", as seen in Figure A.65.
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Figure A.65 Creating an Empty Component

3. Notice that now in ProjectBuilder you will see ContactDe-
tails.wo under the Main.wo entry as seen in Figure A.66.
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Figure A.66 Addition of ContactDetails Component

Linking the Pages Together
1. Now that all our pages are created, we will need a way to 

navigate from the main page to the other pages and from 
each of the other pages back to the main page. This is accom-
plished by using hyperlinks. In ProjectBuilder, double click 
the Main.wo entry and you should see your main page as in 
Figure A.67. If not, select Edit->Layout View from the menu.
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Figure A.67 The Main Contact Page

2. Scroll down to the bottom of the page (below the separation 
line) and click to place the cursor on the form. From the 
menu select WOObjects->WOHyperlink and enter "Com-
pany Entry" to replace "Hyperlink", as seen in Figure A.68.
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Figure A.68 Adding the Company Entry Hyperlink

3. From the popup button labelled "Edit Source" click and select 
"Add Action" and enter enterCompanies for the Name: and 
select Company Entry for the Page returned, as seen in Fig-
ure A.69.
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Figure A.69 Adding the enterCompanies Action

4. You will now see enterCompanies selected. Select and drag 
this entry to the "<WOHyperlink>" symbol and click action, 
as seen in Figure A.70.

Figure A.70 Linking the Action

5. Click to the right of the "Company Entry" hyperlink (outside 
the entire link) and hit the "Enter" or "Return" key to place 
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the next hyperlink on the next line. Repeat the previous steps 
for the "Product Entry" page as seen in Figure A.71 and Fig-
ure A.72 to connect the action "enterProducts".

Figure A.71 Adding the enterProducts Action

Figure A.72 Linking the Product Entry Hyperlink

6. Click to the right of the "Product Entry" hyperlink (outside 
the entire link) and hit the "Enter" or "Return" key to place 
the next hyperlink on the next line. Repeat the previous steps 
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for the "Contact Details" page as seen in Figure A.73 and Fig-
ure A.74 to connect the action displayDetails.

Figure A.73 Adding the displayDetails Action

Figure A.74 Creating the Contact Details Hyperlink

7. Save your project.
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Create the Main Page Hyperlink
1. With the other windows, you will create a single hyperlink to 

navigate back to the Main window. From ProjectBuilder dou-
ble click ProductEntry.wo. Scroll down to the bottom of the 
page and add a new WOHyperlink as you did on the main 
page. This time the hyperlink will be "Main Page" and the ac-
tion will be returnToMainPage, as seen in Figure A.75 and 
Figure A.76 respectively.

Figure A.75 Creating the returnToMainPage Action
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Figure A.76 Creating the Main Page Hyperlink

2. Repeat the above steps for the "CompanyEntry.wo" and 
"ContactDetails.wo" pages. Save the Project and close all of 
the web components. This will bring you back to the Project-
Builder window.

Testing Navigation
1. To test our navigation we first need to build the project, click 

on the "Hammer" button to bring up the builder. In the 
Project Build window, click on the "Hammer" button to begin 
the build process. When the project has finished building you 
should see the result as in Figure A.77. 
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Figure A.77 Building the Application

2. To execute your WebObjects application, go back to the Pro-
jectBuilder window and click on the "Terminal" button. The 
button next to the "i" information button. This will bring up a 
Launch panel. Click on the "Terminal" button to execute your 
application. You are not ready for any data entry yet, just test 
all the hyperlinks to make sure they work.

Contact Details Page
1. From ProjectBuilder, double click the ContactDetails.wo. Se-

lect the left of the "Main Page" hyperlink . 

2. Select Elements->Heading->H1. Then enter Contact Details 
and hit the "Return" or "Enter" key.

3. Next choose Elements->Table. For the Dimensions, choose 
Rows:3 and Columns:2 as seen in Figure A.78, and click 
"OK".
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Figure A.78 Adding Page Tables

4. The first "Cell" will be highlighted, enter Name:, then hit the 
"Tab" key twice to get to the next row. Enter Telephone:, then 
hit the "Tab" key twice to get to the last row and enter 
"EMail". Your window should look like Figure A.79.
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Figure A.79 Adding Table Row Titles

5. Now click to the right of this table and hit the "Return" or 
"Enter" key for a new line. Next choose Elements->Table. For 
the Dimensions, choose Rows:2 and Columns:3 also select 
"First row cells are header cells" and "Second row is wrapped 
in a WORepetition" as seen in Figure A.80, and click "OK".
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Figure A.80 Adding a Repetition Table

6. The first "Cell" will be highlighted, enter Name:, then hit the 
"Tab" key to get to the next column. Enter Price:, then hit the 
"Tab" key to get to the last column and enter Company:, now 
your window should look like Figure A.81.
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Figure A.81 Adding the Table Row Title 

7. Now click to the right of this table for a new line. Next choose 
Elements->Table. For the Dimensions, choose Rows:9 and 
Columns:2, also de-select "First row cells are header cells" 
and "Second row is wrapped in a WORepetition" as seen in 
Figure A.82, and click "OK".
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Figure A.82 Adding Company Detail Page Data Tables

8. The first "Cell" will be highlighted, enter Name:, then hit the 
"Tab" key twice to get to the next row. Enter Address1:, then 
hit the "Tab" key twice to get to the next row and enter 
Address2:, then hit the "Tab" key twice to get to the next row 
and enter  City:, then hit the "Tab" key twice to get to the next 
row and enter "State:" then hit the "Tab" key twice to get to 
the next row and enter "Zip:,  then hit the "Tab" key twice to 
get to the next row and enter "Country:",  then hit the "Tab" 
key twice to get to the next row and enter "Telephone:",  then 
hit the "Tab" key twice to get to the next row and enter 
"EMail:".  Your window should look like Figure A.83.
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Figure A.83 Adding the Table Row Titles

9. Close this window and from Project Builder double click on 
the CompanyEntry.wo section. Click next to the right of the 
"Search for Companys" heading and hit the "Return" or "En-
ter" key. Next choose Elements->Table. For the Dimensions, 
choose Rows:2 and Columns:2, also select "First row cells are 
header cells" and "Second row is wrapped in a WORepeti-
tion" as seen in Figure A.84, and click "OK".
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Figure A.84 Adding a Repetition Table

10.The first "Cell" will be highlighted, enter "Contact Name:", 
then hit the "Tab" key to get to the next column and enter 
"Contact EMail:". Your window should look like Figure A.85.
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Figure A.85 Adding the Contact Table Rows

11. Click next to the right of the table you just created and 
choose Elements->Table. For the Dimensions, choose Rows:2 
and Columns:2 also select "First row cells are header cells" 
and "Second row is wrapped in a WORepetition" as seen in 
Figure A.86, and click "OK".
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Figure A.86 Adding the Product Table

12.The first "Cell" will be highlighted, enter "Product Name:", 
then hit the "Tab" key to get to the next column. "Product 
Price:". Your window should look like Figure A.87.
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Figure A.87 Adding the Table Column Titles

Connect the Table to the Component Page
1. In order to display the Contact name and Contact EMail, we 

have to add the Contact table to the page. Click on the Pro-
jectBuilder window. Select the "Resources" from the left col-
umn. Double click on the "Contacts.eomodeld" to bring up 
the EOModler application. In EOModeler select the Contact 
table and drop it onto your CompanyEntry page as seen in 
Figure A.88.
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Figure A.88 Adding the Contact Table to the Component

2. Click "Add and Configure" on the panel for your contactDis-
playGroup as seen in  Figure A.89.
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Figure A.89 Create contactDisplayGroup

3. Select "Fetches on Load" to ensure that data is loaded into the 
form when it is displayed, and name for Sorting Ascending 
and click "OK" as seen in Figure A.90.
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Figure A.90 Configure the Contact displayGroup

4. Repeat the same for the Product table so you can display the 
Product names and Product Prices. Notice that you now have 
three display groups in your page as seen in Figure A.91.
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Figure A.91 Create the productDisplayGroup

5. Now that you have access to the Contact and Product tables, 
you need to have an object that will map to the data. This is 
where you will add two objects. The first will be a contact ob-
ject. From the web page's Edit Source popup button in the 
lower left frame of the window, select Add Key and enter 
contact of Type "Contact" and check "An instance variable", 
"A method returning the value" and "A method setting the 
value" and click “Add” as see in Figure A.92.
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Figure A.92 Create the contact Data Object

6. Repeat the same for a product of object type Product. When 
you have completed this your page should look like Figure 
A.93.
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Figure A.93 Create the product Data Object

1. Now that you have all the data links in place, it is time to 
make page variables to hold the database values. Double 
click "Cell" under Contact Name: .

2. Choose WebObjects->WOString from the menu. Click the 
WOString you just created and choose WebObjects->WOHy-
perlink from the menu. Your page should look like Figure 
A.94.
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Figure A.94 Adding contact Name Field for the Contact Table

3. Tab to the next "Cell" and choose WebObjects->WOString 
from the menu, and your window now should look like Fig-
ure A.95.
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Figure A.95 Adding contact EMail Field for the Contact Table

4. Repeat the same for the Product Name and Product Price so 
your page will look like Figure A.96. Don't forget to make the 
WOString and WOHyperlink for the Product Name as you 
did for the Contact Name:.
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Figure A.96 Complete the Product data Area

5. To display what contact and product was chosen we will 
have to place a table to display these values. Click to the right 
of the Product Name Product Price table and select Elements-
>Table from the menu. Make the Rows:2 and Columns:2 and 
deselect the "First row cells are header cells" and "Second row 
is wrapped in WORepetition" and click "OK", as seen in Fig-
ure A.97.
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Figure A.97 Configure the Selected Values Table

6. The first "Cell" will be highlighted, enter Contact:, then hit 
the "Tab" key twice to get to the next row. Enter Product:, so 
your window should look like Figure A.98.
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Figure A.98 Add the Selected Values Row Title

7. To hold the selected values you will double click the "Cell" 
next to Contact: and select WebObjects->WOString from the 
menu. Repeat this for the Product "Cell" and your table 
should look like Figure A.99.
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Figure A.99 Add the Selected Values Column data

8. Now you have to make the data connections that will connect 
the database data values to the proper page elements. Click 
the WOString field under Contact Name and from the list of 
instance variables choose contact, name and drag it to the 
WOString and select value from the selections as seen in Fig-
ure A.100.
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Figure A.100 Make the Contact Name value connection

9. Repeat this for the corresponding values for the Contact 
EMail and for the product name and price values as seen in 
Figure A.101.
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Figure A.101 All Connections completed

1. To know what object was selected from the Contact list and 
the Product list we will add the selected object from each of 
the display groups that represent the Contact and Product ta-
bles. Click on the WOString field next to the "Contact:" cell 
and from the list of instance variables navigate to the contact-
DisplayGroup.selectedObject.name and drag it to the WOS-
tring and select value as seen in Figure A.102.
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Figure A.102 Contact Selected Value Connection

2. Repeat the same for the productDisplayGroup.selectedOb-
ject.name as seen in Figure A.103.
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Figure A.103 Make the Product Value Connection

3. The final task is to connect the repetition of the Contact 
Name to the Contact table and the Product Name to the 
Product table. Select the contact.name WOString field. Then 
click on the <WORepetition> entry. select the contactDis-
playGroup.displayedObjects as the list as seen in Figure 
A.104.
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Figure A.104 Connecting the Data Value List Connection

1. Now that you have cancelled the list objects, you have to de-
clare of what object type is the list made of. This is where we 
will connect the contact object to the item. Select the contact 
object and drag to the <WORepetition> and choose "item" 
from the list as seen in Figure A.105.
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Figure A.105 Connect the Data Object for the Repetition

2. Repeat the above steps for the product object and product-
DisplayGroup.displayedObjects

3. Now we need a method to respond to the <WOHyperlink>  
selection of a contact object. So a selectContactObject will 
have to be created as follows:

Listing 0.1 selectContactObject method

   public void selectContactObject() {
       contactDisplayGroup.selectObject(contact);
   }

Place this code right below the selectObject() method.

4. Now that the method is in our project, it is time to connect 
the WOHyperlink to this action. Select and drag the select-
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ContactObject entry to the <WOHyperlink> entry and 
choose action from the list as seen in Figure A.106.

Figure A.106 Connecting the Action for the Hyperlink

5. Now we need a method to respond to the <WOHyperlink> 
selection of a product object. To edit the source, select from 
the "Edit Source" popup button "View Source File". Add the 
following selectProductObject method to the java source.

Listing 0.2 selectProductObject method

   public void selectProductObject() {
       productDisplayGroup.selectObject(product);
   }

Place this code right below the selectContactObject () 
method.
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6. Now that the method is in our project, it is time to connect 
the WOHyperlink to this action. Select and drag the select-
ProductObject entry to the <WOHyperlink> entry and 
choose action from the list as seen in Figure A.107.

Figure A.107 Connect the Action for the Product Name Hyperlink

Congratulations, all of your connections have been made. Your 
page should look like Figure A.108.
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Figure A.108 All Connections Completed

1. The last thing that you have to do is modify the 
saveChanges() method to get the selected values from the 
page to actually be stored in the database. The modifications 
to the method appear in bold below:

Listing 0.3 saveChanges method

   public void saveChanges() throws Exception {
       EOEnterpriseObject aCompany = 
(EOEnterpriseObject)companyDisplayGroup.selectedObject();
       EOEnterpriseObject aContact = 
(EOEnterpriseObject)contactDisplayGroup.selectedObject();
       EOEnterpriseObject aProduct = 
(EOEnterpriseObject)productDisplayGroup.selectedObject();
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aCompany.addObjectToBothSidesOfRelationshipWithKey(aContact, 
"toContact");
       
aCompany.addObjectToBothSidesOfRelationshipWithKey(aProduct, 
"toProduct");
        
       try {
           this.session().defaultEditingContext().saveChanges();
       } catch (Exception exception) {
           // An error occurred during the save. You could 
present an error page which
           // explains the reason for the save failure.
           // The default is to raise an exception which 
presents a diagnostic page.
           System.err.println("Cannot save changes ");
           throw exception;
       }
   }

2. To edit the source select from the "Edit Source" popup button 
"View Source File" and find the saveChanges method and 
enter the modification and save the project. 

Additions to the ContactDetails Page
1. From the ProjectBuilder window, choose the "ContactDe-

tails.wo" page. Double click the "Cell" field next to Name:. 
Choose WebObjects->WOString from the menu, hit the "Tab" 
twice and add another WOString for the Telephone: and hit 
"Tab" twice to add another WOString for the EMail: "Cell" 
value,  as seen in Figure A.109.
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Figure A.109 Adding the data Value Fields

2. Double click on the "Cell" value on the table, under the 
Name: column. Choose WebObjects->WOString from the 
menu, hit the "Tab" and add another WOString for the Price: 
and hit "Tab" to add another WOString for the Company: 
"Cell" value, as seen in Figure A.110.
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Figure A.110 Add the data Value Fields for the Repetition

3. Double click the "Cell" field next to Name:. Choose WebOb-
jects->WOString from the menu, hit the "Tab" twice and add 
another WOString for the Address1: and hit "Tab" twice to 
add another WOString for all the other table: "Cell" values, as 
seen in Figure A.111.
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Figure A.111 Adding the data Value Fields for the Company Details

4. To connect the selected contact coming from the main page, a 
contact object will be added to this page. From the "Edit 
Source" popup button select Add Key with the Name of se-
lectedContact and Type of Contact with "An instance vari-
able", "A method returning the value" and "A method setting 
the value" checked as seen in Figure A.112, and click “Add”.
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Figure A.112 Create the Data Variable for the selectedContact

5. Now it is time to make the connections to the database val-
ues. Select the WOString to the right of the "Name:" field at 
the top of the page. Choose the selectedContact.name value 
and drag it to the <WOString> entry and select value from 
the list as seen in Figure A.113.
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Figure A.113 Connecting the selectedContact Name Value

6. Repeat the above for the Telephone and EMail values as seen 
in Figure A.114.
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Figure A.114 selectedContact data Values connected

1. To be able to access the Company table values, first a com-
pany object will be added, then a companyDisplayGroup 
will be added. To add the company object, select from the 
"Edit Source" popup button select Add Key with the Name of 
company and Type of Company with "An instance variable", 
"A method returning the value" and "A method setting the 
value" checked as seen in Figure A.115, and click "Add".
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Figure A.115 Create a company Data Object

2. Now to add the companyDisplayGroup, select the Company 
table in EOModeler and drag it into the ContactDetails page 
as seen in Figure A.116.
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Figure A.116 Add the Company Data Table to the Component
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3. Click on the “Add & Configure” button as seen in Figure 
A.117.

Figure A.117 Create the companyDisplayGroup

4. For the Display Group Options, check "Has detail data 
source", Master Entity: Contact and Detail Key: to Company, 
check "Fetches on load and name in Ascending Order as seen 
in Figure A.118, click "OK".
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Figure A.118 Configure the Company Display Group

5. To add the values for the Product Name, Product Price and 
Company Name the following will be connected. For the rep-
etition select the WOString under the Name: title in the 
"Name, Price and Company" repetition. 

6. Then select the <WORepetition> field. From the list select the 
companyDisplayGroup.displayedObjects and drag to the 
<WORepetition> and select list as seen in Figure A.119.
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Figure A.119 Define the Display Group Repetition List

7. Now with the list identified, the list object type must be de-
clared. Select the company object and drag it to the 
<WORepetition> and select item as seen in Figure A.120.

Figure A.120 Define the Object for the Repetition

8. Now we will make the field connections to the database. Se-
lect the WOString for the Name field in the repetition and 
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drag the company.toProduct.name for the value as seen in 
Figure A.121. Do the same for the company.toProduct.price.

Figure A.121 Making the Field Connections to the Database

9. For the final column in the repetition select the com-
pany.name and drag that to the selected WOString for the 
"Company" field and select value. All three of the fields are 
now connected as seen in Figure A.122.
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Figure A.122 The Repetition Defined

10. Finally we need to connect the company's database values 
to the last table. The database values will come from the com-
panyDisplayGroup.selectedObject value. 

11. Select the WOString field next to the Name entry. Click 
companyDisplayGroup.selectedObject.name and drag it to 
the <WOString> and select value as seen in Figure A.123.
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Figure A.123 Making the Company data Value Connections

12. Follow the same steps for all of the company fields. When 
you are finished, your page should look like Figure A.124.
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Figure A.124 All Company data Connections Completed

1. Finally if there are more than one company we want to dis-
play the details for the selected company. To allow for the se-
lection of a particular company, select the company.name 
WOString in the table. Choose WebObjects->WOHyperlink 
from the menu as seen in Figure A.125.
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Figure A.125 Adding the Company Hyperlink

2. From the "Edit Source" popup button select View Source. and 
add the following method:

Listing 0.4 selectObject method

   public WOComponent selectObject() {
       companyDisplayGroup.selectObject(company);
       return null;
   }
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3. Now back in the page select the company.name and select 
the <WOHyperlink> and from the list click on selectObject 
and drag to the <WOHyperlink> and choose action as seen 
in Figure A.126.

Figure A.126 Adding the Action to the Hyperlink

Passing of Contact Objects
1. Add the following  Listing 0.5 displayDetails method to 

Main.java. This will pass the selected Contact object to the 
Contact Detail Page. 

Listing 0.5 Main.java

   public ContactDetails displayDetails() {
       ContactDetails nextPage = 
(ContactDetails)pageWithName("ContactDetails");
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       // Initialize your component here
        EOEnterpriseObject selection = 
(EOEnterpriseObject)contactDisplayGroup.selectedObject();
       nextPage.setSelectedContact(selection);

       return nextPage;
   }

2. Add the following highlighted line of code, see  Listing 0.6  to 
the  selectedContact method to the ContactDetails.java. This 
will set the contact into the Master Company object. 

Listing 0.6 ContactDetails.java

   public void setSelectedContact(EOEnterpriseObject 
newSelectedContact) {
       selectedContact = newSelectedContact;
       companyDisplayGroup.setMasterObject(newSelectedContact);
    }

Congratulations, you have completed your first WebObjects appli-
cation using FrontBase as you database. In the next section you are 
going to build and run your application. 
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Running the WOContacts Application

Building the Application
1. From the ProjectBuilder window, you will see the "Hammer" 

button as in Figure A.127.

Figure A.127 The Hammer Button

2. Click on the "Hammer" button to bring up ProjectBuilder's 
Build Panel as seen in Figure A.128.
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Figure A.128 The Build Panel

3. Click on the "Hammer" button from this window and you 
will start the application building process. When the project 
has completed building you will see Figure A.129.

Figure A.129 A Successful Build

Running the Application
1. Back in ProjectBuilder's window, you will see an "Terminal" 

button. Click on this and you will bring up the Launch win-
dow.Click on the "Terminal" button in this panel and your 
web application will launch and bring up your web browser 
with your Main.wo page. See  Figure A.130.
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Figure A.130 The Launch Panel

Adding Contacts
1. Click on the Insert/New Button and enter a new contact, and 

then click on the Save to Database as seen in Figure A.131.

Figure A.131 Add a New Contact

2. Add one more contact as seen in Figure A.132. After saving 
to the database, clicking on the telephone hypertext fields 
will bring up the entered information for each contact.
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Figure A.132 Displaying the Entered Contacts

Adding Products
1. Now click on the Product Entry hyperlink and enter two 

products as you entered two contacts. Remember, click In-
sert/New and enter the information. Then click Save to data-
base as seen in Figure A.133.
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Figure A.133 Saving the Products

2. From the Product Entry page, click on the Main Page hyper-
link to return you to the Contact Entry page. In the Contact 
Entry page click on the Match button to bring up your con-
tact list and select your second contact from the telephone 
hyperlink as seen in Figure A.134.
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Figure A.134 Selecting a Contact

Adding Companies
1. Now click on Company Entry hyperlink to enter two Compa-

nies. To enter the company information you will have to first 
select a contact name. Next, select a product name as seen in 
Figure A.135.
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Figure A.135 Adding the Company

2. To enter the company will now be the same as all the other 
entry steps. Click on the Insert/New, enter the information 
then click on the Save to Database. Using these steps, enter 
Three Companies as seen in Figure A.136. 

NOTE: Remember to select a different Contact and Product BE-
FORE clicking the Insert/New button and entering the information 
then clicking the Save to Database button.
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Figure A.136 Saving the Company

Displaying Company Details
1. With the entry completed, click on the Main Page hyperlink 

to return to the main Contact Entry page. At the Main page 
click on the "Match" button and choose a Contact, then click 
on the Contact Details page.
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2. From the Contact Details page, the First Company is dis-
played Figure A.137. Click on your second company in the 
list and you will see that company's information listed as 
seen in Figure A.138.

Figure A.137 Displaying the First Contact Detail Entry
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Figure A.138 Displaying the Second Contact Detail Entry

Congratulations, you have completed this exercise. While this is not 
a ready-for-primetime application, that would include page format-
ting and error checking, it demonstrates how the WebObjects 
framework was able to integrate with the FrontBase database frame-
work with relative ease.
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Summary
It cannot be overlooked what the database has stored for this appli-
cation. There are three tables; Contact, Company and Product, all 
with relationships to each other that are  resolved on the Contact 
Details page. This is quite an accomplishment for a web based ap-
plication.

I hope this exercise has offered some insight into web based data-
base applications. As always, if you have any questions please visit 
the FrontBase website at www.frontbase.com, for further informa-
tion, support or to download your FREE copy of FrontBase and li-
cense string.

From all of us at FrontBase, Thank You for taking time to read/de-
velop the steps to build this application.
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